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1 Importing, Loading, Saving

This exercise will illustrate some of the items under the FILE and DATA menu.

1. Download AutoBI.csv from regression book website

2. Open AutoBI.csv in NOTEPAD to show it is a comma-separated value. (Note: if you just double-
clicked, the file would open in EXCEL. You can right-click on an EXCEL file icon and see under
properties that it is automatically opened in EXCEL.)

3. Start R and Rcmdr. If you need to re-install Rcmdr, recall from the email that you can use
command: install.packages(”Rcmdr”, dep=TRUE). What this does is install Rcmdr, together
with all of the other packages that Rcmdr requires. To bring Rcmdr into R, type library(Rcmdr)
or go to the R menu Packages > Load Packages and click on Rcmdr.

4. Let’s make some mistakes.

(a) For the AutoBI.csv file, try to Load the file into Rcmdr using: Data > Load. That does not
work.

(b) Using the same AutoBI.csv file, import the file, put a clever name like AutoBI for the
Dataset, and then click ok. Everything looks good until you go into View and see that the
data are not separated into columns.

5. For the AutoBI.csv file, import the file, put a clever name like AutoBI.1 for the Dataset, click
on ”comma” in the ”Field Separator” and then click ok. Everything looks good even in View.
(Note: the decimal-separator ”comma” is for other systems that represent 100.3 as 100,3.)

6. Type str(AutoBI.1) and click Submit.

7. Type head(AutoBI.1) and click Submit.

8. Type tail(AutoBI.1) and click Submit.

9. Compute a new variable Log.Claims with CLMINSUR using Data > Manage variables > Compute
new variable. Function is: log. (Note: Check out R functions link in R Resource section on
Course Website.) View the data set again to see that the new variable is added to the data set
and computed correctly.

10. Go to Data > Active Data Set > Variables in active data set. This produces the function ‘names’
that indicates the variable names. Powerful function that will come in handy when we go to
Regression modeling.

11. Go to Data > Active Data Set and save active data set. Note extension of file. (This is what you
would use for the Data > Load function. This saves your data, including the transformations, in
a data set that can be restored.)

12. Go to Data > Active Data Set and export active data set. This writes the data to a .csv file so
that you can use it in EXCEL, for example.

13. Go to File > save script as and save script. This lets you keep your code for future times.

14. Go to File > save output as. This gives you the output in a text file. (Use courier font for tables
and output so that it lines up better.)
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15. Go to File > save workspace as. This is similar to saving the active data set, but saves everything
in the workspace. So if you have created multiple datasets, then all are saved within this one file.
Whereas in (??), the command only saves the active data set.

16. Now clear all of the working areas: click in the script, then right click to clear the contents. Do
the same for the output and message windows.

17. Type rm(list=ls()). This clears all of the objects from the workspace. Click on the Active Dataset
box and everything disappears. You can see this by typing ls() and you’ll get character(0).

18. Now bring in one of the .RData files using Data > Load. See that all your data are restored.
Now type ls() and see that it lists the name(s) of the datasets in that file.
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2 Subsetting, Summaries and Graphing

This exercise will illustrate some of the items under the GRAPH menu.

1. Download HealthExpend.csv from regression book website.

2. Start R and Rcmdr. If you need to re-install Rcmdr, recall from the email that you can use
command: install.packages(”Rcmdr”, dep=TRUE). This installs Rcmdr, together with all of the
other packages that Rcmdr requires. However, note if other packaes need to be loaded and add
them. To bring Rcmdr into R, type library(Rcmdr) or go to the R menu Packages > Load
Packages and click on Rcmdr.

3. Recall that in R/Rcmdr everything is CASE Sensitive.

4. Go to File > Change working directory to select where you want the data to be placed and
where you want R to look. Remember that you can also change the ‘Start in’ box in the R-icon
properties. Also, the link on the course website for instructions for installing Rcmdr has some
other set-up tips.

5. Import HealthExpend.csv, put a clever name like MEPS for the Dataset, click on ”comma” in
the ”Field Separator” and then click ok.

6. Type str(MEPS) and click Submit. Notice now that there are variables called Factors that are
discrete variables (rather than continuous). We will cover Factors in Chapter 4.

7. Type head(MEPS) and click Submit.

8. Go to Data > Active Data Set > Subset active data set. Include all of the variables (i.e. keep the
box checked). In the subset expression box, type COUNTIP > 0. Put another name for the new
data set, like MEPS.IP and click ok. Note that the active data set (at the top left) has changed
to this new data set.

9. The full dataset is still available. Click the Data set box and click on MEPS to restore it as the
active dataset.

10. Under Statistics > Summaries > Numerical summaries and choose COUNTIP and EXPENDIP
as the variables. (Note you have to push the CNTL key to select multiple variables.)

11. Now, choose MEPS.IP as your active dataset and re-do the numerical summaries for those two
variables. Why such a difference?

12. Now let us practice some plots.

(a) With MEPS.IP, choose Graphs > Boxplot and choose EXPENDIP. Click the box to identify
outliers with a mouse. Close the dialog box when it appears and click on the outlier. Note
that it shows you the observation number of that point. In the top left menu, click stop
locator when done. You can save the graph under File in the graphics window or in Rcmdr
in the Graphs > Save Graph to File.

(b) Let us compare the Boxplot for EXPENDIP for the full dataset. Reselect MEPS as the
active dataset and choose Graphs > Boxplot and choose EXPENDIP. Click the box to
identify outliers with a mouse. Close the dialog box when it appears and click on the
outlier. Note that it shows you the observation number of that point. In the top left menu,
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click stop locator when done. You can save the graph under File in the graphics window or
in Rcmdr in the Graphs > Save Graph to File.

(c) It is hard to view these two graphs side by side to compare. Let us do this a different way.

Type the command"
par(mfrow=c(1,2), oma = c(0,0,2,0))

Note: oma = outer margin area.
This changes the print setting to allow 2 graphs in a window.

(d) Now re-do the two boxplots and see how they are in one R graphics window.

(e) If you want to complete the graph, add the following command:

mtext("Compare two Graphs", outer=TRUE, cex = 1.5)

This will put some margin text above the two graphs. See the Help with R Graphs document
on the course website. Also, note you can re-size the graphs by clicking on a R graphics
window and dragging the window.

(f) You can return to 1 plot per graphics window by changing the mfrow to mfrow=c(1,1) in
the par setting, i.e. just re-submit that code.

(g) You can save the graphs in two ways: one in the File menu in the R graphics window (this
seems to hang up Rcmdr for me) or the other in Rcmdr in the Graphs > Save Graph as
tab. See if the first way works for you. I have found depending which computer I am using,
that Rcmdr does some funny things (like lock-up). This is another reason why I recommend
weaning ourselves off of it and using R.

13. Save your script file (maybe email to yourself) so that you can see what commands that you used
and can re-create in the future.
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3 Simulation and Regression

This exercise will introduce you to the basics of simulation with an application in basic regression. We
will establish the ‘true’ regression parameters and simulate some data. We will use the data then to
estimate the regression parameters and then compare the estimated line with the ‘true’ line. With
simulation, you can re-produce the study quickly (just by re-submitting the code) and see how the
results may change. This is an example of sampling variability.

1. The code that I used in R is attached if you want to use it. At this stage, it would be beneficial
for you to start paying attention to the R code so that you can modify it for use in the future.
Using R directly becomes faster, provides more options, and also does not freeze up the system.
Please remember to save your R scripts as you are working just in case your system freezes.

2. Start R and Rcmdr. The Rcmdr package should still be in your hard drive. Try library(Rcmdr)
to see first, but if you need to re-install Rcmdr, use: install.packages(”Rcmdr”, dep=TRUE). If
other packaes are needed, please add them. To bring Rcmdr into R, type library(Rcmdr) or go
to the R menu Packages > Load Packages and click on Rcmdr.

3. Go to File > Change working directory to select where you want the data to be placed and
where you want R to look. Remember that you can also change the ‘Start in’ box in the R-icon
properties. Also, the link on the course website for instructions for installing Rcmdr has some
other set-up tips.

4. You can type code in the Script Window as well as working from the menus. You can place your
cursor at the end of the line and click the Submit button.

5. I find typing in the code for simulation easier. (For those who are interested, you can see how
Rcmdr produces simulated outcomes. It is in the Distributions Tab. We will be working with the
Gamma and Normal distributions here, but notice the set of distributions available. Rcmdr puts
the data in a matrix which I find harder.) We will simulate some xi’s from a Gamma Distribution
and some εi’s from a Normal Distribution. Recall that in Regression, the xi’s are assumed as
fixed, i.e. given. The Gamma Distribution is just a way to get some data. Type the following
(along with Submit) and remember that R/Rcmdr is CASE sensitive and space sensitive (i.e.
cares about spacing).

(a) num <− 25

(b) beta.0 <− 12500

(c) beta.1 <− 50

(d) sigma <− 2000 (This is our population value of σ for the standard deviation of the error
term.)

(e) x <− rgamma(num, shape = 50, scale = 15)

(f) epsilon <− rnorm(num, mean = 0, sd = sigma) (Note: this is the ε in our linear model.)

The num sets the number of random observations; β0, β1, and σ set the values of the ‘true’
parameters; x and ε are vectors are random variables.

6. Find the sample mean and sample standard deviation of x and ε. Type mean(x) and sd(x) and
mean(epsilon) and sd(epsilon). How do these numbers compare with truth?
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7. Draw histograms of x and ε. You can find histograms in the Rcmdr menu Graphs or use the R
command hist(xxx), where xxx = the variable you would like to graph. What do you think of
these? Are they what you expected?

8. Create the truth vector : y.truth <− beta.0 + beta.1 * x. This is the population version. We do
not know y.truth, but here we do because we are making things up.

9. Now let us combine the values to create our observation vector y : y <− beta.0 + beta.1 * x +
epsilon. This command creates a vector y that is the same length as x and ε. We take our truth
and add a little error to it (which is what we observe).

10. Find the sample mean and standard deviation of y. Why does this not equal the sample standard
deviation of ε?

11. Suppose you wanted to view these observations? If you look at the active dataset, you cannot
view any of the data. Why? These variables have been created in a temporary workspace. You
can see that they exist by typing: ls(). You can still view them using the head() command. Type
head(y), head(x), head(epsilon), head(y.truth). You can see that if you apply the beta.0 and
beta.1 appropriately to each of the x then you match y.truth and if you add ε, you match y.

12. Combine y and x into a dataframe to run a regression. (In this example, it is not necessary as
the variables are in the local workspace, but when you have variables that you will be importing,
they will all be in a dataframe.) Use the code: myDataSet <− data.frame(x,y). Note that these
data are now showing in Rcmdr if you click on the Dataset window.

13. To run a Regression type: RegModel <− lm(y ∼ x, data = myDataSet) and then type sum-
mary(RegModel). The first command runs a regression and puts the results in an object called
RegModel. The second command shows a summary of the results. (If you run multiple regres-
sions, you can name them: RegModel.1, RegModel.2 )

(a) A helpful command is: names().
(b) Type: names(RegModel)
(c) Type: names(summary(RegModel))
(d) The names() command provides you a list of variables that are available for your use in other

aspects of your analysis. For example, type: beta.hat <− coefficients(RegModel) and then
type: beta.hat and click Submit. The coefficients command places the estimated values of
your regression in a vector.

14. You can do this in Rcmdr under the Statistics > Fit Models (and choose either the Linear Regres-
sion or Linear Models entry). The Linear Models is more flexible, as you can do transformations.
So I would recommend using that one. Note that Rcmdr automatically provides the summary
command. Note now, that the regression model that you created has become the active Model
at the top right in Rcmdr. To use this model further in your analysis, make sure that this is
indicated. (This is important when you will be creating different models and all will be in the
workspace. Only one can be active.)

15. Examine the results. How does your value for the intercept and slope terms compare to truth?
Where does the estimate for σ come into play in the regression output?

16. Now let us plot some of the results. You cannot do this in Rcmdr. Type the following code, but
note that # is a comment character in R. No need to type that in. Included as instructions to
you.
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plot(y ~ x, cex=1.5, pch=19, col = c("blue"),
main = "Comparison of Data, Truth and Estimated Regression Line",
xlab = "My label of x", ylab = "My label of y",
data=myDataSet) # click Submit for this block and see what it does.

abline(a = beta.0, b = beta.1, lwd = 4, lty = 2) # click Submit for this block
and see what it does

abline(coef = beta.hat, col = "red", lwd = 3, lty = 1) # click Submit for this block
and see what it does

legend("topleft",c("Observed Data","Truth","Least Squares"),
col=c("blue","black","red"), pch = c(19, 19, 19)) # click Submit for this block

and see what it does

17. What does your graph say about Truth vs. Estimate?

18. We will (or have) learned about the ANOVA Table. You can get this as:

(a) anova.lm(RegModel) in R

(b) anova(RegModel) in Rcmdr under Models > Hypothesis Tests > ANOVA.
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4 Simulation, Regression, and Confidence/Prediction Intervals

This exercise will use simulation with an application in basic regression and introduce you to the
calculation and graphing of confidence and prediction intervals. As before, we will establish the ‘true’
regression parameters and simulate some data. We will use the data then to estimate the regression
parameters and then compare the estimated line with the ‘true’ line.

Note: There is a plug-in in Rcmdr called RcmdrPlugin.HH. You will need to install it on your
computer as you did Rcmdr (i.e. from a CRAN mirror). In theory, you can load Rcmdr and then within
Rcmdr under Tools, you could load the Plugin. My computers have been crashing so I worked out this
example for you in R. (You could try the following two command simultaneously: library(Rcmdr) and
library(RcmdrPlugin.HH) – that may work.) Under the Model menu some items related to prediction
intervals come up. You can explore those on your own. I wanted to provide you something here that
would work independently of Rcmdr.

1. The code that I used in R is attached if you want to use it. The example is modified from one lo-
cated on the web at:
http://stat.ethz.ch/R-manual/R-patched/library/stats/html/predict.lm.html
Please remember to save your R scripts as you are working just in case your system freezes.

2. Start R.

3. Remember that R is case-sensitive and space-sensitive.

4. We will simulate some xi’s from a Normal Distribution (0, 1) and some εi’s from a Normal
Distribution(0, 1). Recall that in Regression, the xi’s are assumed as fixed, i.e. given.

(a) x <− rnorm(15)

(b) y <− x + rnorm(15)

(c) xy <− data.frame(x,y)

Note here we left off the mean and sd for the Normal deviates. The default in R is that these
values are 0 and 1 respectively.

5. View the data by typing xy (the name of our dataset. Type summary(xy) and sd(xy) to find
the summary statistics of x and y. These will come in handy if you wanted to verify some of the
results by hand.

6. Run a regression using: RegModel <− lm(y ∼ x) and then type summary(RegModel). Note the
results. Recall the ‘true’ model does NOT contain an intercept term, but this one has it. Is the
intercept term significant? We will re-address the intercept term later in this exercise.

7. One nice command is model.matrix. You can view the data used to estimate the model by typing
model.matrix(RegModel). Note there is a column of 1’s and then your data. The column of 1’s
shows that there is an intercept term estimated in the model. We will see in chapter 3, that all
x’s in the model will be included in the model.matrix (that is, it is linked to the x’s that you
actually include in the model, not all those that are in the data frame).

8. Built-in to R is a predict function. If you type: predict(RegModel), the fitted values will be
shown. You can also get at this by typing: fitted.values(RegModel). This is an example of
multiple ways of doing the same thing. And they get the same answer too!
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9. For this example, we know that the range of a N (0, 1) variable (i.e. x here), can be captured
between (−3, 3). (Really you need to go to (−5, 5), but the chance of that happening is really
small. If you feel better you can change the example and do these more extreme limits.) To do
this, we create a new dataset, cleverly called ‘new’ using the sequence command. Type: new <−
data.frame(x = seq(-3, 3, 0.5)). Then type new. See how x varies from -3 to 3 by increments of
0.5. We use these values of x to find fitted values on the line and then find the associated values
on the confidence and prediction intervals.

10. Type: predict(RegModel, new, se.fit = TRUE). This shows you the fitted values for all of the x’s
in the data frame new. Note that these fitted values depend on the model estimated, so it does
include an intercept term. Of course, you could check the calculations by hand just to verify.

11. To obtain the confidence intervals (for the expected value of the line itself at a particular value
of x) and the prediction intervals (for a new observation), type:

mylevel <- 0.95 # provides a flexible way of changing the confidence level
pred.w.clim <- predict(RegModel, new, interval="confidence", level = mylevel)
pred.w.plim <- predict(RegModel, new, interval="prediction", level = mylevel)

The first command finds the values associated with the confidence interval for each of x’s in your
data new (i.e. the x’s from -3 to 3). You can see the data by typing pred.w.clim or pred.w.plim.
Note that these data sets include the fitted value and then the upper and lower values.

12. Now let us do the graph.

mytitle <- paste("Comparison of Fitted Values, Confidence Interval,
& Prediction Interval at ", mylevel*100, "% Significance", sep = "")

matplot(new$x,cbind(pred.w.clim, pred.w.plim[,-1]),
lty=c(1,2,2,3,3), type="l", xlab="x", ylab="Values of y", main=mytitle)

legend("topleft",c("Fitted Value","Lower Confidence Interval",
"Upper Confidence Interval", "Lower Prediction Interval",
"Upper Prediction Interval"),

col=palette(), pch = c(19, 19, 19, 19, 19))

The line with mytitle provides a way to include the mylevel dynamically in the title. So that
when you change the mylevel from 0.95 to 0.90 and re-run to get new values, you do not need to
remember to change the title in the graph.

Actually the graph on in the original example on the web, did not include a legend (which is
included here). If you print pred.w.clim and pred.w.plim, you see that both contain fitted values.
The cbind function combines the columns. But to graph, we only need one column for the fitted
values. So the ‘-1’ parameter in pred.w.plim says to include all columns, BUT the first one.
(Remember matrix notation is (rows, columns). Same is true here within the [ ].)

The order of the colors follows the palette function: type palette() to see the default order. R
uses the colors in order and if it needs more, then it just repeats. Since the pred.w.clim is listed
first, it prints first. Check out the order and see that it makes sense to you.

Including the legend helps so that the reader does not need to think so hard.



Act Sci 654: Regression and Time Series for Actuaries 11

13. We can modify the graph to help make it clearer and simpler for the reader:

matplot(new$x,cbind(pred.w.clim, pred.w.plim[,-1]),
col=c("black","red","red","blue","blue"),lwd=c(2,1,1,1.5,1.5),
lty=c(1,2,2,3,3), type="l", xlab=" Values of x", ylab="Values of y",
main = mytitle)

legend("topleft",c("Fitted Value","Confidence Interval",
"Prediction Interval"),

col=c("black","red","blue"), pch = c(19, 19, 19))

Now it is clearer which is the confidence interval and which is the prediction interval. And the
pictures are what we talked about in class. You can check the values using the formulas provided.

14. Finally let us see what happens to these lines when we constrain the model and not have an
intercept term. You can copy your previous code and make some changes (but be careful) or
type the code below. Note that the Regression Model statement has a ‘-1’ that indicates NO
INTERCEPT. And the title has changed so as to be indicated appropriately in the graph. Here
I am just showing the simpler of the matplots.

## Model without intercept term
RegModel.o <- lm(y ~ x -1 )

model.matrix(RegModel.o)
summary(RegModel.o)
names(RegModel.o)
predict(RegModel.o)
fitted.values(RegModel.o) ## same as predict

predict(RegModel.o, new, se.fit = TRUE)
pred.w.clim.o <- predict(RegModel.o, new, interval="confidence", level = mylevel)
pred.w.plim.o <- predict(RegModel.o, new, interval="prediction", level = mylevel)

mytitle1 <- paste("Comparison of Fitted Values, Confidence Interval,
& Prediction Interval with NO Intercept Term at ", mylevel*100,
"% Significance", sep = "")

matplot(new$x,cbind(pred.w.clim.o, pred.w.plim.o[,-1]),
col=c("black","red","red","blue","blue"),lwd=c(2,1,1,1.5,1.5),
lty=c(1,2,2,3,3), type="l", xlab=" Values of x", ylab="Values of y",
main=mytitle1)

legend("topleft",c("Fitted Value","Confidence Interval",
"Prediction Interval"),

col=c("black","red","blue"), pch = c(19, 19, 19))
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Entire R code

# Modified Example from
# http://stat.ethz.ch/R-manual/R-patched/library/stats/html/predict.lm.html

## Simulated Example
x <- rnorm(15)
y <- x + rnorm(15)
xy <- data.frame(x,y)

summary(xy)
sd(xy)

## Model with intercept term
RegModel <- lm(y ~ x)

model.matrix(RegModel)
summary(RegModel)
names(RegModel)
predict(RegModel)
fitted.values(RegModel) ## same as predict

new <- data.frame(x = seq(-3, 3, 0.5))
predict(RegModel, new, se.fit = TRUE)

mylevel <- 0.95

pred.w.clim <- predict(RegModel, new, interval="confidence", level = mylevel)
pred.w.plim <- predict(RegModel, new, interval="prediction", level = mylevel)

mytitle <- paste("Comparison of Fitted Values, Confidence Interval,
& Prediction Interval at ", mylevel*100, "% Significance", sep = "")

matplot(new$x,cbind(pred.w.clim, pred.w.plim[,-1]),
lty=c(1,2,2,3,3), type="l", xlab="x", ylab="Values of y", main=mytitle)

legend("topleft",c("Fitted Value","Lower Confidence Interval",
"Upper Confidence Interval", "Lower Prediction Interval",
"Upper Prediction Interval"),

col=palette(), pch = c(19, 19, 19, 19, 19))

matplot(new$x,cbind(pred.w.clim, pred.w.plim[,-1]),
col=c("black","red","red","blue","blue"),lwd=c(2,1,1,1.5,1.5),
lty=c(1,2,2,3,3), type="l", xlab=" Values of x", ylab="Values of y",
main = mytitle)

legend("topleft",c("Fitted Value","Confidence Interval",
"Prediction Interval"),
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col=c("black","red","blue"), pch = c(19, 19, 19))

## Model without intercept term
RegModel.o <- lm(y ~ x -1 )

model.matrix(RegModel.o)
summary(RegModel.o)
names(RegModel.o)
predict(RegModel.o)
fitted.values(RegModel.o) ## same as predict

predict(RegModel.o, new, se.fit = TRUE)
pred.w.clim.o <- predict(RegModel.o, new, interval="confidence", level = mylevel)
pred.w.plim.o <- predict(RegModel.o, new, interval="prediction", level = mylevel)

mytitle1 <- paste("Comparison of Fitted Values, Confidence Interval,
& Prediction Interval with NO Intercept Term at ", mylevel*100,
"% Significance", sep = "")

matplot(new$x,cbind(pred.w.clim.o, pred.w.plim.o[,-1]),
col=c("black","red","red","blue","blue"),lwd=c(2,1,1,1.5,1.5),
lty=c(1,2,2,3,3), type="l", xlab=" Values of x", ylab="Values of y",
main=mytitle1)

legend("topleft",c("Fitted Value","Confidence Interval",
"Prediction Interval"),

col=c("black","red","blue"), pch = c(19, 19, 19))
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5 Impact of Outlier on Regression Results

This exercise will use the dataset Outliers.csv on the Regression Book Website. These data are those
used in the example on page 43 of the textbook. We will focus on just the first two columns of the
dataset: X and Y .

1. The code that I used in R is attached if you want to use it.

2. Start R/Rcmdr. You can use Rcmdr to submit a couple of lines at one time. That might be
easier than using the R GUI. Also recall that R is case-sensitive and space-sensitive.

3. For this exercise, we will use the package calibrate to help with labeling on the graphs. You will
need to install the package and then load it with library(calibrate).

4. Read in the data into a dataset named Outlier and do a str() to see the information within the
dataset. It is a small dataset, so it would be helpful to view it. You can type the name of the
dataset to view. See how the data are listed: the 19 base points plus 3 extra points that are A,
B, and C in Figure 2.7.

5. Let us subset the data so that we have 4 datasets: (1) 19 base points, (2) 19 base points + point
A, (3) 19 base points + point B, and (4) 19 base points + point C.

Outlier.0 <- Outlier[c(1:19), 1:2]

Outlier.A <- Outlier[c(1:19,20), 1:2]

Outlier.B <- Outlier[c(1:19,21), 1:2]

Outlier.C <- Outlier[c(1:19,22), 1:2]

Recall that the c() combines items and that Outlier[rows, columns] is the dataset. The first line
then pulls the first 19 rows and first columns of Outlier. The last line pulls the first 19 rows +
the 22nd row along with the first two columns. You can view the data sets by typing the name.

6. This next set of code is where you need the calibrate package. You can type:

plot(Outlier$X,Outlier$Y, pch = 19, cex = 1.5, main="Plot of the Outlier Data")
textxy(4.3,8.0, "A", cx = 1.0, dcol = "darkred") # puts label at x-y coordinate
textxy(9.5,8.0, "B", cx = 1.0, dcol = "royalblue4")
textxy(9.5,2.5, "C", cx = 1.0, dcol = "forestgreen")

The first line is our usual plot command, where we make the dots solid, a little bigger, and a
title. The next 3 lines are ways are labeling the data points. The first entries are the (x, y) values
of the point, how you would want them to be labeled, the relative size, and the color. Note the
commands are slightly different than the basic R plot. (There are other ways of doing this too;
this is just one way.)

7. Run regression models on Y ∼ X for each of the four models and summarize the results. Note
how different are the intercept and slope terms and compare your results to that on page 44.

8. Let us put all of the plots on one page for easier reference:
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plot.new() # creates a new plot
par(mfrow=c(2,2), oma = c(0,0,2,0))
plot(Outlier.0$X,Outlier.0$Y, main="No Influential Points")
abline(Model.0)
plot(Outlier.A$X,Outlier.A$Y, main="Base Points + A")

abline(Model.A)
plot(Outlier.B$X,Outlier.B$Y, main="Base Points + B")

abline(Model.B)
plot(Outlier.C$X,Outlier.C$Y, main="Base Points + C")

abline(Model.C)
mtext("Plots of Data vs. Least Squares Lines", outer = TRUE, cex = 1.5)

This is nice, but it is hard to compare as the axes are of different scales. So the following set of
code corrects this issue:

plot.new()
par(mfrow=c(2,2), oma = c(0,0,2,0))
plot(Outlier.0$X,Outlier.0$Y, main="No Influential Points", xlim= c(0,10),

ylim = c(0,8))
abline(Model.0)
plot(Outlier.A$X,Outlier.A$Y, main="Base Points + A", xlim= c(0,10),
ylim = c(0,8))

abline(Model.A)
plot(Outlier.B$X,Outlier.B$Y, main="Base Points + B", xlim= c(0,10),
ylim = c(0,8))

abline(Model.B)
plot(Outlier.C$X,Outlier.C$Y, main="Base Points + C", xlim= c(0,10),
ylim = c(0,8))

abline(Model.C)
mtext("Plots of Data vs. Least Squares Lines", outer = TRUE, cex = 1.5)

Here the xlim and ylim set the limits for the x and y axes. Note the c() notation again here.

9. One approach to handling outliers and high leverage points is through the use of indicator vari-
ables. One way to do this is the following:

## create an indicator variable and run the regression
Outlier.C$C <- 1*(Outlier.C$X == 9.5)
Model.C1 <- lm(Y ~ X + C, data=Outlier.C)
summary(Model.C1)

Essentially, the 1 ∗ (Outlier.C$X == 9.5) create an indicator variable, with a 1 when the con-
dition is true, and 0 otherwise. This new variable, C, is included in the model as an additional
explanatory variable. We will learn more about extra variables in chapter 3.

10. Note the output from the regression. Look at the intercept and slope terms. Which model does it
resemble? What happens to the fitted value/residual value for the observation with an X = 9.5?
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11. Now let us plot all of the graphs for comparison. Same code as above (so just copy the prior code
and add the last 3 lines (other than the mtext command).

## plot original data and fit
plot.new()
par(mfrow=c(3,2), oma = c(0,0,2,0))
plot(Outlier.0$X,Outlier.0$Y, main="No Influential Points", xlim= c(0,10),

ylim = c(0,8))
abline(Model.0)
plot(Outlier.A$X,Outlier.A$Y, main="Base Points + A", xlim= c(0,10),
ylim = c(0,8))

abline(Model.A)
plot(Outlier.B$X,Outlier.B$Y, main="Base Points + B", xlim= c(0,10),
ylim = c(0,8))

abline(Model.B)
plot(Outlier.C$X,Outlier.C$Y, main="Base Points + C", xlim= c(0,10),
ylim = c(0,8))

abline(Model.C)
plot(Outlier.C$X,Outlier.C$Y, main="Base Points + C + Indicator on C",
xlim= c(0,10), ylim = c(0,8))
abline(Model.C1)
mtext("Plots of Data vs. Least Squares Lines", outer = TRUE, cex = 1.5)
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#### Outlier examples

rm(list=ls())
library(calibrate) # to get text labels in graphs

Outlier <-read.csv("D:/ActSci654/DataForFrees/OutlierExample.csv",
header=TRUE)

# shows variables in dataset
str(Outlier)

## list out dataset
Outlier

Outlier.0 <- Outlier[c(1:19), 1:2]
Outlier.A <- Outlier[c(1:19,20), 1:2]
Outlier.B <- Outlier[c(1:19,21), 1:2]
Outlier.C <- Outlier[c(1:19,22), 1:2]

## plot "big" data set with all outliers, together with text labels
plot(Outlier$X,Outlier$Y, pch = 19, cex = 1.5)
textxy(4.3,8.0, "A", cx = 1.0, dcol = "darkred") # puts label at x-y coordinate
textxy(9.5,8.0, "B", cx = 1.0, dcol = "royalblue4")
textxy(9.5,2.5, "C", cx = 1.0, dcol = "forestgreen")

## run models

Model.0 <- lm(Y ~ X, data=Outlier.0)
summary(Model.0)
Model.A <- lm(Y ~ X, data=Outlier.A)

summary(Model.A)
Model.B <- lm(Y ~ X, data=Outlier.B)

summary(Model.B)
Model.C <- lm(Y ~ X, data=Outlier.C)
summary(Model.C)

## plot original data and fit
plot.new()
par(mfrow=c(2,2), oma = c(0,0,2,0))
plot(Outlier.0$X,Outlier.0$Y, main="No Influential Points")
abline(Model.0)
plot(Outlier.A$X,Outlier.A$Y, main="Base Points + A")

abline(Model.A)
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plot(Outlier.B$X,Outlier.B$Y, main="Base Points + B")
abline(Model.B)
plot(Outlier.C$X,Outlier.C$Y, main="Base Points + C")

abline(Model.C)
mtext("Plots of Data vs. Least Squares Lines", outer = TRUE, cex = 1.5)

## plot original data and fit -- re-do axes limits
plot.new()
par(mfrow=c(2,2), oma = c(0,0,2,0))
plot(Outlier.0$X,Outlier.0$Y, main="No Influential Points", xlim= c(0,10),

ylim = c(0,8))
abline(Model.0)
plot(Outlier.A$X,Outlier.A$Y, main="Base Points + A", xlim= c(0,10),

ylim = c(0,8))
abline(Model.A)
plot(Outlier.B$X,Outlier.B$Y, main="Base Points + B", xlim= c(0,10),

ylim = c(0,8))
abline(Model.B)
plot(Outlier.C$X,Outlier.C$Y, main="Base Points + C", xlim= c(0,10),

ylim = c(0,8))
abline(Model.C)
mtext("Plots of Data vs. Least Squares Lines", outer = TRUE, cex = 1.5)

## Modified model with point C
## include an indicator variable on C

Outlier.C$C <- 1*(Outlier.C$X == 9.5)
Model.C1 <- lm(Y ~ X + C, data=Outlier.C)
summary(Model.C1)

## plot original data and fit -- re-do axes limits
plot.new()
par(mfrow=c(3,2), oma = c(0,0,2,0))
plot(Outlier.0$X,Outlier.0$Y, main="No Influential Points", xlim= c(0,10),

ylim = c(0,8))
abline(Model.0)
plot(Outlier.A$X,Outlier.A$Y, main="Base Points + A", xlim= c(0,10),

ylim = c(0,8))
abline(Model.A)
plot(Outlier.B$X,Outlier.B$Y, main="Base Points + B", xlim= c(0,10),

ylim = c(0,8))
abline(Model.B)
plot(Outlier.C$X,Outlier.C$Y, main="Base Points + C", xlim= c(0,10),

ylim = c(0,8))
abline(Model.C)
plot(Outlier.C$X,Outlier.C$Y, main="Base Points + C + Indicator on C",
xlim= c(0,10),
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ylim = c(0,8))
abline(Model.C1)
mtext("Plots of Data vs. Least Squares Lines", outer = TRUE, cex = 1.5)
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6 Missing Data and Added Variable Approach

This exercise will consider the case when you want to create an added variable plot and the original
data set has missing values.

1. The code that I used in R is attached if you want to use it. The data uses the UNLifeExpectan-
cyModified.csv file from the Regression Book website. Please remember to save your R scripts as
you are working just in case your system freezes.

2. Start R/Rcmdr. You can use Rcmdr to submit a couple of lines at one time. That might be
easier than using the R GUI. Also recall that R is case-sensitive and space-sensitive.

3. Load the libraries Hmisc and car with the commands: library(Hmisc) and library(car). Note the
log file to see which functions are masked with the loading of these packages.

4. Read in the data to a dataset and call it UN . Run a str(UN ) command and see the list of
variables. We will focus on the variables LIFEEXP , FERTILITY , PUBLICEDUCATION ,
PRIV ATEHEALTH .

5. Pull these variables in a separate dataset to see correlations and missing data using

UN.sub <−UN [ , c(”LIFEEXP ”, ”FERTILITY ”, ”PUBLICEDUCATION”, ”PRIV ATEHEALTH”)]

Note that we are including all of the rows of the dataset, but only a subset of the variables.

6. Using the Hmisc package, find the pair-wise correlation of these variables using the command
rcorr(as.matrix(UN.sub), type = ”pearson”). You can see that there are 185 observations in
the entire dataset, but in some of the pairs, many of the observations are missing.

7. You could also do a summary(UN.sub) to see the actual number of missing observations for each
variable.

8. Remember that a variable may be missing for one observation and another observation may have
other missing variables.

9. Run a regression of

lm(LIFEEXP ∼ FERTILITY +PUBLICEDUCATION+PRIV ATEHEALTH, data = UN )

You can see that the regression ran despite having missing values for some of the variables. The
output does indicate that it deleted 33 observations. The end result is 148 degrees of freedom.
(To get to the total number, take 148 + 4 regression coefficients + 33 missing = 185)

10. Let us create an added variable plot. (This first way will bring errors, so be prepared.)

11. Run a regression of

RegModel.1 <−lm(LIFEEXP ∼ FERTILITY + PRIV ATEHEALTH, data = UN )

Note that the degrees of freedom is 177. This is the first clue to upcoming problems (as the first
regression had 148 df.)
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12. Run the next regression of

RegModel.2 <−lm(PUBLICEDUCATION ∼ FERTILITY +PRIV ATEHEALTH, data = UN )

Here we only have 149 degrees of freedom.

13. We want to plot the residuals against each other in a scatterplot. Essentially RegModel.1 takes
LIFEEXP and removes the explained variation from FERTILITY and PRIV ATEHEALTH ,
while RegModel.2 takes PUBLICEDUCATION and removes the explained variation from
FERTILITY and PRIV ATEHEALTH . The residuals of each regression represent the unex-
plained variation in LIFEEXP and PUBLICEDUCATION after controlling for FERTILITY
and PRIV ATEHEALTH .

14. If you run the following statement:

RegModel.2c <−lm(residuals(RegModel.2a)∼ residuals(RegModel.2b))

you get an error saying that the lengths of the two vectors (meaning the residuals) differ. Really
we had the clue that they would be from the df from the regression output.

15. If you try to blindly run a plot statement, you get the same error.

16. To correct this, we need to remove the missing data. One way would be with the following
statement:

## one way does the whole data set but removes too much
UN.NA <- UN[complete.cases(UN),]
str(UN.NA)

You end up with 45 observations of the original 185. Simple, but the command retains only
complete observations where values for all 16 variables in the data set exist.

17. The following commands remove the missing data for just the variables we want to include:

## another way just deletes NA’s for those variables
UN.NA<-UN[!is.na(UN$LIFEEXP) & !is.na(UN$PUBLICEDUCATION) &
!is.na(UN$ FERTILITY) & !is.na(UN$PRIVATEHEALTH),]

The & operate as and, while the !is.na is the not equal to NA function. Doing a str(UN.NA)
shows that this dataset has 152 observations which is what we want.

18. To finish the analysis you can run the following code:

## added variable plot
RegModel.2a1 <- lm(LIFEEXP ~ FERTILITY + PRIVATEHEALTH, data=UN.NA)
summary(RegModel.2a1)
## Note there are 149 degrees of freedom

RegModel.2b1 <- lm(PUBLICEDUCATION ~ FERTILITY + PRIVATEHEALTH, data=UN.NA)
summary(RegModel.2b1)
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## Note there are 149 degrees of freedom

RegModel.2c1 <- lm(residuals(RegModel.2a1) ~ residuals(RegModel.2b1))
summary(RegModel.2c1)

plot(residuals(RegModel.2b1),residuals(RegModel.2a1), main="Added Variable
Plot of LIFEEXP vs. PUBLICEDUCATION ", xlab = "Residuals of PUBLICEDUCATION
~ FERTILITY + PRIVATEHEALTH",
ylab = "Residuals of LIFEEXP ~ FERTILITY + PRIVATEHEALTH", pch = 19)

cor(residuals(RegModel.2a1),residuals(RegModel.2b1))

resid <- cbind(residuals(RegModel.2a1),residuals(RegModel.2b1))
rcorr(as.matrix(resid), type="pearson")

Now the residuals are of equal length. Check the output to see the relationship between the
correlation and the p-values for the residuals.
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library(Hmisc) # for correlations
library(car) # vif

rm(list=ls())
UN <-read.table("d:/ActSci654/DataForFrees/UNLifeExpectancyModified.csv",

header=TRUE, sep=",", na.strings="NA", dec=".", strip.white=TRUE)

str(UN)

UN.sub <- UN[,c("LIFEEXP","FERTILITY","PUBLICEDUCATION","PRIVATEHEALTH")]
rcorr(as.matrix(UN.sub), type="pearson")

summary(UN.sub)
sd(UN.sub)
head(UN.sub)

RegModel.1 <- lm(LIFEEXP ~ FERTILITY +PUBLICEDUCATION +
PRIVATEHEALTH, data=UN)

summary(RegModel.1)

## added variable plot part d
RegModel.2a <- lm(LIFEEXP ~ FERTILITY +PRIVATEHEALTH, data=UN)
summary(RegModel.2a)
## Note there are 177 degrees of freedom

RegModel.2b <- lm(PUBLICEDUCATION ~ FERTILITY + PRIVATEHEALTH, data=UN)
summary(RegModel.2b)
## Note there are 149 degrees of freedom

## will not run
RegModel.2c <- lm(residuals(RegModel.2a ) ~ residuals(RegModel.2b ))
summary(RegModel.2c )

## will not plot
plot(residuals(RegModel.2b ),residuals(RegModel.2a1), main="Added Variable

Plot of LIFEEXP vs. PUBLICEDUCATION ", xlab = "Residuals of PUBLICEDUCATION
~ FERTILITY + PRIVATEHEALTH",
ylab = "Residuals of LIFEEXP ~ FERTILITY + PRIVATEHEALTH", pch = 19)

## one way does the whole data set but removes too much
UN.NA <- UN[complete.cases(UN),]
str(UN.NA)

## another way just deletes NA’s for those variables
UN.NA<-UN[!is.na(UN$LIFEEXP) & !is.na(UN$PUBLICEDUCATION) &
!is.na(UN$ FERTILITY) & !is.na(UN$PRIVATEHEALTH),]

## added variable plot part d
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RegModel.2a1 <- lm(LIFEEXP ~ FERTILITY + PRIVATEHEALTH, data=UN.NA)
summary(RegModel.2a1)
## Note there are 149 degrees of freedom

RegModel.2b1 <- lm(PUBLICEDUCATION ~ FERTILITY + PRIVATEHEALTH, data=UN.NA)
summary(RegModel.2b1)
## Note there are 149 degrees of freedom

RegModel.2c1 <- lm(residuals(RegModel.2a1) ~ residuals(RegModel.2b1))
summary(RegModel.2c1)

plot(residuals(RegModel.2b1),residuals(RegModel.2a1), main="Added Variable
Plot of LIFEEXP vs. PUBLICEDUCATION ", xlab = "Residuals of PUBLICEDUCATION
~ FERTILITY + PRIVATEHEALTH",
ylab = "Residuals of LIFEEXP ~ FERTILITY + PRIVATEHEALTH", pch = 19)

cor(residuals(RegModel.2a1),residuals(RegModel.2b1))

resid <- cbind(residuals(RegModel.2a1),residuals(RegModel.2b1))
rcorr(as.matrix(resid), type="pearson")
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7 Categorical Regression With and Without Intercept Term

This exercise will compare the output of regression when you have a binary variable as the only
explanatory variable and (i) include an intercept term versus (ii) excluding an intercept term using a
factor variable.

The TermLife.csv dataset is used. In the data set GENDER is coded as a numeric variable as
0 = Female and 1 = Male.

We define two new variables and add them to the dataset Term:

Term$Gender.f <- factor(Term$GENDER, labels=c(’Female’,’Male’))

## change order of levels
Term$Gender.f1 <- factor(Term$Gender.f, levels=c(’Male’,’Female’))

Gender.f is now a factor variable (categorical). Note the labels command defines that the 0’s are
Females and the 1’s are Males. Similarly, Gender.f1 re-orders the levels of the Gender.f so that
now Males are first. This switching of levels impacts which is the reference category in the regression
analysis.

Assume that we have taken a subset of the data and use only those observations where FACE > 0
and the GENDER variable. We call that new dataset Face.0.

If you do a str() on Face.0, you will see that GENDER is numeric, while Gender.f and Gender.f1
show as factors. Also, as a frame of reference:

FACE Mean
Overall 747,600.0
Female 111,621.6
Male 846,449.2

Our task is to compare the regression output of FACE on GENDER in 4 different ways:

1. Regression of FACE on the binary variable GENDER (where 0 = Female and 1 = Male).

2. Regression of FACE on the factor GENDER (called Gender.f), where Female is the first level and Male
the second.

3. Regression of FACE on the factor GENDER (called Gender.f1), where Male is the first level and Female
the second.

4. Regression of FACE on the factor GENDER (called Gender.f1), but excluding an intercept term.

The output:

1. Regression of FACE on GENDER
The coefficient for GENDER (representing Male) has a p-value of 0.0127, with the R2 of 0.02251.
This example shows that a variable, GENDER, is statistically significant in explaining the vari-
ability of FACE, but alone, only explains 2% of the variation. Compare the coefficient of the
intercept with the mean for Females. Compare the sum of the coefficient of the intercept and the
Gender variable to the mean for Males.
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lm(formula = FACE ~ GENDER, data = Face.0)

Residuals:
Min 1Q Median 3Q Max

-845649 -757949 -596449 -26535 13153551

Coefficients:
Estimate Std. Error t value Pr(>|t|)

(Intercept) 111622 272646 0.409 0.6826
GENDER 734828 293074 2.507 0.0127 *
---
Signif. codes: 0 ’***’ 0.001 ’**’ 0.01 ’*’ 0.05 ’.’ 0.1 ’ ’ 1

Residual standard error: 1658000 on 273 degrees of freedom
Multiple R-squared: 0.02251,Adjusted R-squared: 0.01893
F-statistic: 6.287 on 1 and 273 DF, p-value: 0.01275

2. Regression of FACE on Gender.f
The results for this regression are identical to that in Regression (??) even though we used
GENDER as a categorical variable. Here the reference category is Female.

lm(formula = FACE ~ Gender.f, data = Face.0)

Residuals:
Min 1Q Median 3Q Max

-845649 -757949 -596449 -26535 13153551

Coefficients:
Estimate Std. Error t value Pr(>|t|)

(Intercept) 111622 272646 0.409 0.6826
Gender.fMale 734828 293074 2.507 0.0127 *
---
Signif. codes: 0 ’***’ 0.001 ’**’ 0.01 ’*’ 0.05 ’.’ 0.1 ’ ’ 1

Residual standard error: 1658000 on 273 degrees of freedom
Multiple R-squared: 0.02251,Adjusted R-squared: 0.01893
F-statistic: 6.287 on 1 and 273 DF, p-value: 0.01275

3. Regression of FACE on Gender.f1 (but changed the order of the levels)
The summary results for this regression are identical to that in Regression (??) and (??). Here
Male is the omitted category. The t-statistic on the GENDER variable is the same, as well as
the diagnostics. To obtain an estimate for Males, we just use the intercept term (as we would
multiply the Female coefficient by 0). Also included in this analysis is the ANOVA table to be
used as comparison in Regression (??).

Find the SS Total for FACE. You find this by finding the variance of FACE multiplied by (number
of observations - 1). Compare this number to the sum of the SSR (Gender.f1 in this case) and
SSR (Residuals) in the ANOVA table. This sum is equal to the SS Total.
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lm(formula = FACE ~ Gender.f1, data = Face.0)

Residuals:
Min 1Q Median 3Q Max

-845649 -757949 -596449 -26535 13153551

Coefficients:
Estimate Std. Error t value Pr(>|t|)

(Intercept) 846449 107501 7.874 8.15e-14 ***
Gender.f1Female -734828 293074 -2.507 0.0127 *
---
Signif. codes: 0 ’***’ 0.001 ’**’ 0.01 ’*’ 0.05 ’.’ 0.1 ’ ’ 1

Residual standard error: 1658000 on 273 degrees of freedom
Multiple R-squared: 0.02251,Adjusted R-squared: 0.01893
F-statistic: 6.287 on 1 and 273 DF, p-value: 0.01275

> Analysis of Variance Table

Response: FACE
Df Sum Sq Mean Sq F value Pr(>F)

Gender.f1 1 1.7291e+13 1.7291e+13 6.2866 0.01275 *
Residuals 273 7.5087e+14 2.7504e+12
---
Signif. codes: 0 ’***’ 0.001 ’**’ 0.01 ’*’ 0.05 ’.’ 0.1 ’ ’ 1

4. Regression of FACE on Gender.f NO INTERCEPT
In this last regression, we conduct a regression without an intercept term. Think of the ‘-1’ term
as a vector that removes the constant term from all of the rows of the design matrix. We notice
that the estimates for Female and Male agree with the estimates for FACE for Female and Male.
The p-value for Female is the same as the p-value for the intercept term in Regressions (??)
and (??). While the p-value for Male is the same as the the p-value for the intercept term in
Regression (??). The Residual standard error (s) is the same as in Regressions (??), (??), and
(??).

But the R2, R2
a, and F-statistic (and its p-value) are vastly different. Why is this so? This

question is answered after the result.

lm(formula = FACE ~ Gender.f1 - 1, data = Face.0)

Residuals:
Min 1Q Median 3Q Max

-845649 -757949 -596449 -26535 13153551

Coefficients:
Estimate Std. Error t value Pr(>|t|)

Gender.f1Male 846449 107501 7.874 8.15e-14 ***
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Gender.f1Female 111622 272646 0.409 0.683
---
Signif. codes: 0 ’***’ 0.001 ’**’ 0.01 ’*’ 0.05 ’.’ 0.1 ’ ’ 1

Residual standard error: 1658000 on 273 degrees of freedom
Multiple R-squared: 0.1855,Adjusted R-squared: 0.1795
F-statistic: 31.08 on 2 and 273 DF, p-value: 6.89e-13

> Analysis of Variance Table

Response: FACE
Df Sum Sq Mean Sq F value Pr(>F)

Gender.f1 2 1.7098e+14 8.5491e+13 31.083 6.89e-13 ***
Residuals 273 7.5087e+14 2.7504e+12
---
Signif. codes: 0 ’***’ 0.001 ’**’ 0.01 ’*’ 0.05 ’.’ 0.1 ’ ’ 1

In this regression, note that the ANOVA shows a degree of freedom of 2 for the factor variable.
The degrees of freedom for the residuals stay at the same level as before. Recall, we removed the
intercept term. Thus, the Total SS for this ANOVA table is equal to the

∑
FACE2, as the mean

of FACE is assumed as 0. There are 2 degrees of freedom for the Gender factor, as there are two
explanatory variables included in the model (and NO intercept term).

Here the hypothesis test is:
H0 : βFemales = βMales = 0
H1 : At least one of βFemales or βMales �= 0

Since the coefficients of Female and Male are the means of FACE for Females and Males respec-
tively, then the hypothesis test is equivalent to:
H0 : Mean of Face for Females = Mean of Face for Males = 0
H1 : At least one of Mean of Face for Females or Mean of Face for Males �= 0

Given the sample means earlier, it is no surprise that we reject the hypothesis that the means
are equal to 0.

As a contrast with Regression (??) including an intercept term, the corresponding hypotheses
are: H0 : βFemales = βMales = 0 (Looks at differences from overall mean of FACE)
H1 : At least one of βFemales or βMales �= 0
Here the null hypothesis is that you would use the overall mean of FACE for an estimate (i.e.
the slope of the line is horizontal at the overall mean).

The hypothesis test is equivalent to:
H0 : Mean of Face for Females = Mean of Face for Males
H1 : Mean of Face for Females Not equal to Mean of Face for Males
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Again, from the sample statistics above, you would not conclude that the mean of FACE for Males =
mean of FACE for Females. You would again reject the null hypothesis.

In conclusion, all of the models are equivalent. You just need to be aware of the summary statistics
in the regression models and what they are trying to tell you.
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R-code for this analysis

rm(list=ls())
Term <- read.csv("D:/ActSci654/DataForFrees/TermLife.csv",

header = TRUE)

Term$Gender.f <- factor(Term$GENDER, labels=c(’Female’,’Male’))

## change order of levels
Term$Gender.f1 <- factor(Term$Gender.f, levels=c(’Male’,’Female’))

## subset data to remove those values of FACE == 0
Face.0 <- Term[Term$FACE > 0 , ]

str(Face.0)

nobs <- length(Face.0$FACE)

# Find summary statsitics
summary(Face.0$FACE)
tapply(Face.0$FACE,Face.0$Gender.f, mean)

RegMod <- lm(FACE ~ GENDER, data = Face.0)
summary(RegMod)

RegMod.1 <- lm(FACE ~ Gender.f, data = Face.0)
summary(RegMod.1)

RegMod.2 <- lm(FACE ~ Gender.f1, data = Face.0)
summary(RegMod.2)
anova(RegMod.2)

## compare to SST.2
var <- sd(Face.0$FACE) * sd(Face.0$FACE)*(nobs - 1)
## total sum of squares
SST.2 <- 1.7291e+13 + 7.5087e+14
## sum of squares of FACE
SS <- t(Face.0$FACE) %*% Face.0$FACE
SST.4 <- 1.7098e+14 + 7.5087e+14

RegMod.3 <- lm(FACE ~ Gender.f1 -1, data = Face.0)
summary(RegMod.3)
anova(RegMod.3)
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8 More on Categorical Variables

This exercise demonstrates differences in regression output and interpretation using categorical vari-
ables.

1. The code that I used in R is attached if you want to use it.

2. The data uses the UNLifeExpectancyModified.csv file from the course website.
Please remember to save your R scripts as you are working just in case your system freezes.

3. Start R/Rcmdr. You can use Rcmdr to submit a couple of lines at one time. That might be
easier than using the R GUI. Also recall that R is case-sensitive and space-sensitive.

4. Open the UNLifeExpectancyModified.csv file, call your data frame UN and do a str() command
to see the variables.

5. Create a histogram of HEALTHEXPEND, 2004 Health expenditures per capita in US dollars.
Note the skewness in the data. So take a log(HEALTHEXPEND) and do a histogram of that,
along with a qqplot. In R, you can type qqnorm(name − of − variable) to get the plot. Recall
that you can type par(mfrow = c(1, 2)) to change the parameters for the graphs to get 2 graphs
in one output window.

6. Let us take a subset of the data and put it in a separate data frame, UN.sub. Use the following
command:

UN.sub <−UN [, c(”Ln.Health”, ”REGION”, ”FERTILITY ”, ”PHY SICIAN”)]

View the data set by typing: head(UN.sub). See that just the 4 variables are in the data frame,
using all of the rows.

7. Now do a correlation on UN.sub using the function from Hmisc package called rcorr. Type:
rcorr(as.matrix(UN.sub), type = ”pearson”). How do you interpret the correlations? Are they
significant?

8. Recall that REGION is a categorical variable for region of the world, FERTILITY is the births
per woman, Ln.Health is the logarithm of the 2004 Health Expenditures, and PHYSICIAN is the
variable for the number of physicians per 100,000 people. So, how do you interpret the correlation
of REGION with the other variables? The calculation worked numerically as the variable is read
into R as a numeric variable. The description is as a category. Taken literally, the output says
that as REGION gets larger in ‘number’, then Ln.Health gets larger. What does it mean for
REGION to get larger in ‘number’? Does that have any interpretable value? Let us delve into
this further.

9. Before we do, let us first create a categorical variable for REGION , called Region.f .

UN$Region.f <- factor(UN$REGION, labels=c("Arab States", "East Asia & Pacific",
"Latin American & Carribean","South Asia","Southern Europe",
"Sub-Saharan Africa","Central & Eastern Europe",
"High-Income OECD")

levels(UN$Region.f)
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The first command creates the factor variable with labels. The second command shows you what
are the levels for that variable. Now if we do a str(UN), we see that we have two variables for
Region, one is a numeric variable, one is a categorical variable. Before we move on, try doing a
correlation of Region.f with Ln.Health. What happens? Not surprisingly, the correlation will
not work with a categorical variable.

10. Now create a new data frame that contains no missing data for
(”Ln.Health”,”REGION”,”FERTILITY”,”PHYSICIAN”).

## just delete NA’s for those variables
UN.NA<-UN[!is.na(UN$Ln.Health) & !is.na(UN$REGION) &
!is.na(UN$FERTILITY) & !is.na(UN$PHYSICIAN),]

str(UN.NA)

There are now 175 observations in the data frame (as compared to 185 in the UN data frame.

11. Run a regression of Ln.Health ∼ REGION using data frame = UN.NA. This regression shows
that REGION is significant with a p-value of 0.0032. Now interestingly, we learned in basic
regression (which this is), that the p-value of the regression should be equivalent to the p-value
from the correlation. (Of course too, you can find the correlation of (Ln.Health, REGION)
using the regression coefficient and the standard deviation of Ln.Health and REGION ).) But
the p-values are close, but not equivalent. Why? (Remember the missing data?)

12. But again, what is the interpretation of using REGION as a numeric variable? The regression
says that when you go from Region 1 to Region 2 that is the same change in Ln.Health as going
from Region 5 to Region 6. Does this make sense? Look at the categories. These are Regions of
the world. Is there an order to the labels?

13. Using REGION as a numeric variable, here, does not make sense. So we use the factor version
of REGION .

14. Run a regression of Ln.Health ∼ Region.f . Now, the regions are like ‘buckets’, not a numeric
value. In this version with an intercept, we have what is shown in the book as y = μ+ τj + ε. See
the text on page 126 under equation (4.11) for an thorough explanation. Essentially, the μ here
is that of the reference category (say μr , Arab States. And the τj are differences of μj and μr .

15. If you run a regression without an intercept term, each level is represented in the output. This
form is consistent with equation (4.7). You can compare your output without an intercept term
with the means by category. This code uses the ddply function as part of the plyr package.

RegModel.2a <- lm(Ln.Health ~ Region.f - 1, data=UN.NA)
summary(RegModel.2a)

ddply(UN.NA,~ Region.f, summarise, count=length(Ln.Health),
mean=mean(Ln.Health), sd=sd(Ln.Health))
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16. But looking at the output, the standard deviations in the summary from ddply do not match
the standard error shown in the regression output (without an intercept term). How can that
be? They measure different things. The standard deviation in the summary output measures
the spread of Ln.Health within each of the Regions. That is, given a particular Region, what is
the standard deviation of Ln.Health? The standard error of the regression coefficient, measures
the error in the estimate of the regression coefficient. Formula (4.8) shows that the value of the
standard error of the regression coefficient is s√

nj
. Note that s is that of the residual standard

error for the regression.

17. You can do a box plot by Region to illustrate any difference.

par(mfrow=c(1,1)) # resets the parameter back to one plot per window
boxplot(Ln.Health ~ Region.f, data = UN.NA,main="Plot of Log(Health Expenditures)
By Region") # this needs some tinkering to get all of the labels plotted

18. Finally run a regression on Ln.Health ∼ Region.f + FERTILITY + PHY SICIAN . What
if the question was asked whether Region is a good variable to include in the model? We do a
partial F-test.

RegModel.3 <- lm(Ln.Health ~ Region.f + FERTILITY + PHYSICIAN, data=UN.NA)
summary(RegModel.3)

RegModel.3a <- lm(Ln.Health ~ FERTILITY + PHYSICIAN, data=UN.NA)
summary(RegModel.3a)

You would then do a partial F-test using the hypothesis: H0 : Region should not be in the
model, versus H1: Region should be in the model. You would use equation (4.4) (or a variant)
to calculate. Here p = 7, dffull = 165, R2

full = 0.7894 and R2
reduced = 0.6327:

F − ratio =
R2

full − R2
reduced

1− R2
full

· n − (k + p + 1)
p

= 17.539

(Note: This variation of formula (4.4) reflects that the full model has k + p variables, while the
reduced model has k variables. Thus the numerator has p degrees of freedom.)

19. Otherwise, you can use the anova command. BUT, you need to be careful!! The ANOVA table
groups the Region factor as one variable.

RegModel.3 <- lm(Ln.Health ~ Region.f + FERTILITY + PHYSICIAN, data=UN.NA)
anova(RegModel.3)

RegModel.3b <- lm(Ln.Health ~ FERTILITY + PHYSICIAN + Region.f, data=UN.NA)
anova(RegModel.3b)
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Same model, but the Region.f variable is in different positions in the R statement. Without going
into much explanation, if you are going to use this command, the order must be right. The second
one is the correct order.

Another command to get the appropriate output is: drop1(RegModel.3,∼ ., test = ”F”). It uses
the original model, but does a different method to get the F statistics. Note that the F stat of
the anova output matches the output of the partial F-test output.



Act Sci 654: Regression and Time Series for Actuaries 35

library(Hmisc) # for correlations
library(car) # vif
library(plyr) # for means by group (ddply)
library(psych) # for nice descriptives and means by group
library(Rcmdr)

rm(list=ls())
UN <-read.table("d:/ActSci654/DataForFrees/UNLifeExpectancyModified.csv",

header=TRUE, sep=",", na.strings="NA", dec=".", strip.white=TRUE)

str(UN)

hist(UN$HEALTHEXPEND)

UN$Ln.Health <- log(UN$HEALTHEXPEND)

par(mfrow=c(1,2))
hist(UN$Ln.Health)
qqnorm(UN$Ln.Health)

UN.sub <- UN[,c("Ln.Health","REGION","FERTILITY","PHYSICIAN")]
rcorr(as.matrix(UN.sub), type="pearson")

UN$Region.f <- factor(UN$REGION, labels=c("Arab States", "East Asia & Pacific",
"Latin American & Carribean","South Asia","Southern Europe",
"Sub-Saharan Africa","Central & Eastern Europe",
"High-Income OECD"))

levels(UN$Region.f)

UN.sub <- UN[,c("Ln.Health","REGION","Region.f")]
rcorr(as.matrix(UN.sub), type="pearson")

## just delete NA’s for those variables
UN.NA<-UN[!is.na(UN$Ln.Health) & !is.na(UN$REGION) &
!is.na(UN$FERTILITY) & !is.na(UN$PHYSICIAN),]

str(UN.NA)

#### Part a
RegModel.1 <- lm(Ln.Health ~ REGION, data=UN.NA)
summary(RegModel.1)
anova(RegModel.1)

RegModel.1a <- lm(Ln.Health ~ REGION, data=UN)
summary(RegModel.1a)

RegModel.2 <- lm(Ln.Health ~ Region.f, data=UN.NA)
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summary(RegModel.2)
anova(RegModel.2)

RegModel.2a <- lm(Ln.Health ~ Region.f - 1, data=UN.NA)
summary(RegModel.2a)

ddply(UN.NA,~ Region.f, summarise, count=length(Ln.Health),
mean=mean(Ln.Health), sd=sd(Ln.Health))

par(mfrow=c(1,1))
boxplot(Ln.Health ~ Region.f, data = UN.NA,main="Plot of Log(Health Expenditures)
By Region")

RegModel.3 <- lm(Ln.Health ~ Region.f + FERTILITY + PHYSICIAN, data=UN.NA)
summary(RegModel.3)

RegModel.3a <- lm(Ln.Health ~ FERTILITY + PHYSICIAN, data=UN.NA)
summary(RegModel.3a)

anova(RegModel.3)
RegModel.3b <- lm(Ln.Health ~ FERTILITY + PHYSICIAN + Region.f, data=UN.NA)
anova(RegModel.3b)
drop1(RegModel.3,~.,test="F")
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9 Example of Residual Plots

This exercise uses simulation to generate some data and then we will explore the data omitting some
variables in the regression to examine the residual plots.

1. The code that I used in R is attached if you want to use it.

2. Please remember to save your R scripts as you are working just in case your system freezes.

3. Start R/Rcmdr. You can use Rcmdr to submit a couple of lines at one time. That might be
easier than using the R GUI. Also recall that R is case-sensitive and space-sensitive.

4. Load the library Hmisc using the command: library(Hmisc).

5. Let us generate the data:

## generate the data

x1 <- 3* runif(100, min=0, max=1)
x2 <- 2* runif(100, min=0, max=1)
error <- rnorm(100, mean = 0, sd = 2)

y <- 0.5 + 5*x1 + 7*x2 + error ## true model

Here we established two explanatory variables, x1 and x2 and tied them to y in a linear model.
This is what we call ‘truth’.

6. Using the ls() command, list the objects in your workspace. Note: the way we set this up, there
is no dataset combining all variables.

7. Construct a histogram of y and a qqplot of y using:

par(mfrow = c(1,2)) # puts both the histogram and qqplot in one window
hist(y, main= "Histogram of y")

qqnorm(y)
qqline(y) # this adds a line to the qq-plot.

Each time you construct this example, that is, generate new data, you would generate different
x’s and different y’s. You can play with this example by also changing the number of random
numbers you generate in the sample. Here we generate 100.

8. Suppose you decide just to plunge in and run a model of y on x1 only.

## example one: leave out variable x2 from model estimation
Model.1 <- lm(y ~ x1)
summary(Model.1)
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resid.1 <- residuals(Model.1)

par(mfrow = c(1,3))
plot(x1, y, pch= 19, main="Plot of x1 vs y")
abline(Model.1) # puts regression line in plot
plot(x1, resid.1, pch= 19, main="Plot of x1 vs residuals")
plot(x2, resid.1, pch= 19, main="Plot of x2 vs residuals from y ~ x1")

9. Examine the plots. The one on the far left plots y vs. x1. The plot shows a nice linear relationship.
What about the one in the center? This is a plot of the residuals from the regression of y ∼ x1.
So it looks like, after removing the impact of x1, there is no other relationship between y and x1,
i.e. the pattern looks random. You can do a correlation of resid.1 and x1 to confirm this. What
about the one on the far right? This is a graph between resid.1 and x2. So after you remove the
effects of x1 from y and see what you have left, there seems to be a relationship between resid.1
and x2. This is the clue to add x2 to the model. You can also check the correlation between
resid.1 and x2.

10. Just to look at this relationship another way, plot y vs. x2 and compare that against resid.1 and
x2 (residuals from y ∼ x1 vs. x2).

par(mfrow = c(1,2))
plot(x2, y, pch= 19, main="Plot of x2 vs y")
plot(x2, resid.1, pch= 19, main="Plot of x2 vs residuals of y ~ x1")

The pictures are similar, but different. How could you explain the difference?

11. Run a regression of y vs. x1 + x2. See how closely your estimates are to truth. Compare your
results to the regression found by regressing y only on x1.

12. If you had other variables, you would follow the same process by taking the residuals and plotting
against the variables not in the model. Recall the added variable plot that we learned earlier.
This approach follows what we did there.

13. Now clear your workspace so we can do another example.

rm(list=ls()) ## get rid of objects
ls() # see it is empty now

## re-generate the data
x1 <- 3* runif(100, min=0, max=1)
x2 <- 2* runif(100, min=0, max=1)
error <- rnorm(100, mean = 0, sd = 2)

## Revised Truth
y <- 0.5 + 5*x1 + 3*x1*x1 + 7*x2 + error
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Notice that we added an x2
1 term to the model.

14. Run a regression of y ∼ x1 + x2

Model.2 <- lm(y ~ x1 + x2)
summary(Model.2)

resid.2 <- residuals(Model.2)

par(mfrow = c(1,2))
plot(x1, y, pch= 19, main="Plot of x1 vs y")
plot(x1, resid.2, pch= 19, main="Plot of x1 vs residuals")

The first plot shows a linear relationship between x1 and y. What does the second plot show?
Here it is the residuals (the remaining variation of y after removing the effects of x1 and x2)
plotted against x1. There looks to be a quadratic relationship, so this is the clue to add the
squared term.

15. Run a regression of y ∼ x1 +x2 +x2
1 and compare your results against the other model and truth.
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# Residual plots

library(Hmisc)
rm(list=ls())

## generate the data
x1 <- 3* runif(100, min=0, max=1)
x2 <- 2* runif(100, min=0, max=1)
error <- rnorm(100, mean = 0, sd = 2)

y <- 0.5 + 5*x1 + 7*x2 + error ## true model

ls() ## objects in workspace

par(mfrow = c(1,2))
hist(y, main= "Histogram of y")
# normal fit
qqnorm(y)
qqline(y)

data <- data.frame(y, x1, x2)
rcorr(as.matrix(data), type="pearson")

## example one: leave out variable x2 from model estimation
Model.1 <- lm(y ~ x1)
summary(Model.1)

resid.1 <- residuals(Model.1)

par(mfrow = c(1,3))
plot(x1, y, pch= 19, main="Plot of x1 vs y")
abline(Model.1)
plot(x1, resid.1, pch= 19, main="Plot of x1 vs residuals")
plot(x2, resid.1, pch= 19, main="Plot of x2 vs residuals from y ~ x1")

# Find correlations of residuals
rcorr(x1, resid.1)
r.1 <- rcorr(x1, resid.1)
names(r.1) # way to see more digits in output
r.1$r
r.1$P

par(mfrow = c(1,2))
plot(x2, y, pch= 19, main="Plot of x2 vs y")
plot(x2, resid.1, pch= 19, main="Plot of x2 vs residuals of y ~ x1")

rcorr(x2, resid.1)
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r.1a <- rcorr(x2, resid.1)
r.1a$r
r.1a$P

Model.1a <- lm(y ~ x1 + x2)
summary(Model.1a)

#######################
rm(list=ls()) ## get rid of objects
ls()

## re-generate the data
x1 <- 3* runif(100, min=0, max=1)
x2 <- 2* runif(100, min=0, max=1)
error <- rnorm(100, mean = 0, sd = 2)

## Revised Truth
y <- 0.5 + 5*x1 + 3*x1*x1 + 7*x2 + error

par(mfrow = c(1,2))
hist(y, main= "Histogram of y with squared x1")
# normal fit
qqnorm(y)
qqline(y)

## example two: leave out squared x1 from model
Model.2 <- lm(y ~ x1 + x2)
summary(Model.2)

resid.2 <- residuals(Model.2)

par(mfrow = c(1,2))
plot(x1, y, pch= 19, main="Plot of x1 vs y")
plot(x1, resid.2, pch= 19, main="Plot of x1 vs residuals")

r.2 <- rcorr(x1, resid.2)
r.2$r
r.2$P

plot(x2, y, pch= 19, main="Plot of x2 vs y")
plot(x2, resid.2, pch= 19, main="Plot of x2 vs residuals of Model.2")

r.2a <- rcorr(x2, resid.2)
r.2a$r
r.2a$P

Model.2a <- lm(y ~ x1 + x1*x1 + x2)
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summary(Model.2a)
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10 Influential Points and Residual Analysis

This exercise demonstrates differences in regression output.

1. The code that I used in R is attached if you want to use it.

2. The exercise uses simulated data from the course website.

3. Please remember to save your R scripts as you are working just in case your system freezes.

4. Start R/Rcmdr. You can use Rcmdr to submit a couple of lines at one time. That might be
easier than using the R GUI. Also recall that R is case-sensitive and space-sensitive.

5. You will need the following libraries for this exercise:

library(car) # avPlots
library(MPV) # gets PRESS statistic
library(stats) # get stats functions
library(Rlab) ## for bernoulli
library(MASS)
library(car) # vif
library(Hmisc) # for correlation

6. Read in Ex11Residual.csv and do a str() to see the variables. y is the dependent variable.

7. Do a correlation matrix and a scatterplot matrix on these variables. Look at the relationships.

8. You decide to run a regression on all of the variables. What are your conclusions?

9. Now let us look at the residual plots and see if there are other things going on.

(a) Use the avPlots(Model), where Model is your model name. These are the added variable
plots that we introduced in Chapter 3. What do these indicate? Anything?

(b) Use the vif(Model), where Model is your model name to get the variance inflation factors.
What does this indicate? Any collinearity amongst the explanatory variables?

(c) We can examine the leverage in a couple of ways:

leverage <- hatvalues(Model)
lev <- hat(model.matrix(Model))

summary(leverage)
hist(leverage)

plot(hat(model.matrix(Model)), type = "h")

The hatvalues(Model) or hat(model.matrix(Model)) command is a way to save the leverage
values (hii). You can summarize the leverage. What is the average value of the leverage
and does this tie to what we discussed in class? What about the histogram? What are the
conclusions? And the plot of the leverages?
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(d) We can also examine the residuals.

summary(rstudent(Model))
hist(rstudent(Model))
plot(rstudent(Model), type = "h")

Any concerns here?

(e) Finally we discussed the Press and AIC statistics.

PRESS(Model)
AIC(Model)

These two results are not useful by themselves, but in relation to other model summaries.

(f) From the original summary statistics, it seems that x3 is not significant, but the original
scatterplots looked like there was some relationship to x2. So run two other models, one of
y ∼ x1 + x2 and the other one of y ∼ x1 + x3. Do a vif, Press, and AIC on each of these
models and compare the results to the model using x1, x2, x3.

(g) As final information, the ”true” model is: y <−0.5 + 5 ∗ x1 + 7 ∗ x2 + error, where error ∼
N (0, σ = 2). Do your results approximate truth?

10. Read in Ex11Residual1.csv and do a str() to see the variables. y is the dependent variable.

11. Do a correlation matrix and a scatterplot matrix on these variables. Look at the relationships.

12. You decide to run a regression on x1, x2, x4. What are your conclusions? Get the vif, Press, and
AIC for comparison purposes to later models.

13. Now let us look at the residual plots and see if there are other things going on.

(a) Use the avPlots(Model), where Model is your model name. Here are the added variable
plots that we introduced in Chapter 3. What do these indicate? Anything?

(b) We can also examine the residuals. It looks like something interesting is going on with
respect to the residuals and x4.

resid.mod1b <- rstandard(Model.1b)

colx4.f = c("red","blue")[as.factor(data$x4)]

par(mfrow = c(2,2), oma = c(0,0,2,0))
plot(data$x1,resid.mod1b, col=colx4.f, pch=20, cex=2)
abline(h=0,col=3,lty=3)
plot(data$x2,resid.mod1b, col=colx4.f, pch=20, cex=2)
abline(h=0,col=3,lty=3)
plot(data$x3,resid.mod1b, col=colx4.f, pch=20, cex=2)
abline(h=0,col=3,lty=3)
plot(data$x4,resid.mod1b, col=colx4.f, pch=20, cex=2)
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abline(h=0,col=3,lty=3)
mtext("Residual Analysis for Additional Relationships",
outer = TRUE, cex = 1.5)

Here we color-coded the binary variable x4. Look at the relationship of the residuals from the
regression and x3. Interesting. Even though the simple correlations showed no relationship
between y and x3, now there looks to be something going on when we look at the residuals
by group.

(c) So now include x3 in the model and see if things improve. Do the avplots, vif, Press, and
AIC. Do the above color-coded residual plots. Answer is, something else is going on.

(d) Let’s add an interaction term. You could create an additional variable x5 <−x3 ∗ x4 or use
the x3 : x4 in the regression equation.

Model.1a <- lm(y ~ x1 + x2 + x3 + x4 + x3:x4,data=data )
summary(Model.1a)

Do all of the above avplots, vif, Press, AIC and residual plots and see what you find.

(e) As final information, the ”true” model is: y <−1.5−5 ∗x1+7 ∗x2+2∗x3+3.33∗x4−2.5∗
x5 + error, where x5 = x3 ∗ x4 and error ∼ N (0, σ = 2.7). Do your results approximate
truth?
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library(car) # avPlots
library(MPV) # gets PRESS statistic
library(stats) # get stats functions
library(Rlab) ## for bernoulli
library(MASS)
library(car) # vif

library(Hmisc) # for correlation

rm(list=ls())

data <- read.csv(file="f:/ActSci654/ClassExamples/Ex11Residual.csv",
header = TRUE)

str(data)

rcorr(as.matrix(data), type="pearson") # type can be pearson or spearman

pairs(~data$y + data$x1 + data$x2 + data$x3,
main="Simple Scatterplot Matrix")

Model <- lm(y ~ x1 + x2 + x3, data=data )
summary(Model)

avPlots(Model, id.method="identify") # added variable plot

## collinearity
vif(Model)

## ways to get leverage
leverage <- hatvalues(Model)

lev <- hat(model.matrix(Model))

summary(leverage)
hist(leverage)

plot(hat(model.matrix(Model)), type = "h")

## residulas
plot(rstudent(Model), type = "h")

## cook’s distance
plot(cooks.distance(Model), type ="h")

## Press statistic
PRESS(Model)
AIC(Model)
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## try other models
Model.a <- lm(y ~ x1 + x2, data=data )
summary(Model.a)

vif(Model.a)
PRESS(Model.a)

Model.b <- lm(y ~ x1 + x3, data=data )
summary(Model.b)
vif(Model.b)
PRESS(Model.b)
AIC(Model.b)

################# NEw Exercise #####################################

rm(list=ls())

data <- read.csv(file="d:/ActSci654/ClassExamples/Ex11Residual1.csv",
header = TRUE)

str(data)

rcorr(as.matrix(data), type="pearson")

pairs(~data$y + data$x1 + data$x2 + data$x3 +
data$x4, main="Simple Scatterplot Matrix")

Model.1b <- lm(y ~ x1 + x2 + x4, data=data )
summary(Model.1b)
vif(Model.1b)

PRESS(Model.1b)
AIC(Model.1b)

avPlots(Model.1b) # added variable plot

## check out residuals of x4 on x1, x2, x3
resid.mod1b <- rstandard(Model.1b)

colx4.f = c("red","blue")[as.factor(data$x4)]

par(mfrow = c(2,2), oma = c(0,0,2,0))
plot(data$x1,resid.mod1b, col=colx4.f, pch=20, cex=2)
abline(h=0,col=3,lty=3)
plot(data$x2,resid.mod1b, col=colx4.f, pch=20, cex=2)
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abline(h=0,col=3,lty=3)
plot(data$x3,resid.mod1b, col=colx4.f, pch=20, cex=2)
abline(h=0,col=3,lty=3)
plot(data$x4,resid.mod1b, col=colx4.f, pch=20, cex=2)
abline(h=0,col=3,lty=3)
mtext("Residual Analysis for Additional Relationships",
outer = TRUE, cex = 1.5)

Model.1 <- lm(y ~ x1 + x2 + x3 + x4, data=data )
summary(Model.1)

avPlots(Model.1) # added variable plot

## all plots
par(mfrow = c(2, 3), oma = c(0, 0, 2, 0))

plot(Model.1, which = c(1:6))

vif(Model.1)

PRESS(Model.1)
AIC(Model.1)

## check out residuals of x4 on x1, x2, x3
resid.mod1 <- rstandard(Model.1)

colx4.f = c("red","blue")[as.factor(data$x4)]

par(mfrow = c(2,2), oma = c(0,0,2,0))
plot(data$x1,resid.mod1, col=colx4.f, pch=20, cex=2)
abline(h=0,col=3,lty=3)
plot(data$x2,resid.mod1, col=colx4.f, pch=20, cex=2)
abline(h=0,col=3,lty=3)
plot(data$x3,resid.mod1, col=colx4.f, pch=20, cex=2)
abline(h=0,col=3,lty=3)
plot(data$x4,resid.mod1, col=colx4.f, pch=20, cex=2)
abline(h=0,col=3,lty=3)
mtext("Residual Analysis for Additional Relationships",
outer = TRUE, cex = 1.5)

## add interaction term

Model.1a <- lm(y ~ x1 + x2 + x3 + x4 + x3:x4,
data=data )

summary(Model.1a)

avPlots(Model.1a) # added variable plot
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# Influence Plot
influencePlot(Model.1a, id.method="identify",
main="Influence Plot",
sub="Circle size is proportial to Cook’s Distance" )

# Cook’s D plot
# identify D values > 4/(n)
cutoff <- 4/((nrow(model.matrix(Model.1a))))
plot(Model.1a, which=4, cook.levels=cutoff)

par(mfrow = c(2, 3), oma = c(0, 0, 2, 0))
plot(Model.1a, which = c(1:6))

vif(Model.1a)

PRESS(Model.1a)
AIC(Model.1a)


